Service Outage
Incident Report for greytHR
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 23, 2019 - 11:11 IST
Update
Service is restored
Posted 5 months ago. Mar 23, 2019 - 08:06 IST
Investigating
We are currently experience greytHR service disruption. Customers are unable to login and use the application at this time. We are currently investigating the issue.
Posted 5 months ago. Mar 23, 2019 - 07:36 IST
This incident affected: greytHR.