Poor response time and slow page loading
Incident Report for greytHR
Resolved
This incident has been resolved.
Posted Jan 02, 2020 - 18:15 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 02, 2020 - 15:15 IST
Investigating
We are experiencing slow page loading and poor response times. We are currently looking into the issue.
Posted Jan 02, 2020 - 11:56 IST
This incident affected: greytHR.